

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">

	<head id="ctl00_Head"><link href="//fonts.googleapis.com/css?family=Open+Sans:400italic,400,700" rel="stylesheet" type="text/css" /><title>
	Mugabe mourns fallen comrades - DailyNews Live
</title><meta id="ctl00_MetaKeywords" name="keywords" content="National Heroes Acre, Robert Mugabe, Zanu PF, Naison Khutshwekhaya Ndlovu, Peter Chanetsa, Zenzo Ntuliki, James Murozvi" /><meta id="ctl00_MetaDescription" name="description" content="HARARE - President Robert Mugabe yesterday told Zanu PF supporters of his heartache at witnessing the high number of deaths that the former liberation movement has had to contend with this year — including having to preside over their burials at the National Heroes Acre.

Speaking at the burial..." /><meta name="SKYPE_TOOLBAR" content="SKYPE_TOOLBAR_PARSER_COMPATIBLE" /><meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" /><meta http-equiv="Content-Language" content="en-AU" /><meta id="ctl00_Generator" name="generator" content="Gloo CMS (C2 Media Pty Ltd)" /><link rel="shortcut icon" href="/favicon.ico" /><link rel="stylesheet" href="/compress/115/web.css" media="screen,handheld" /><link rel="stylesheet" href="/compress/1/web/common/css/custom/print.css" media="print" />

		<script type="text/javascript" src="/compress/113/web.js"></script>
		
		<link rel="alternate" type="application/rss+xml" href="/rss/articles.xml" title="Latest News" />

		<script type="text/javascript">
			if (navigator.userAgent.match(/iPad/i)) { document.write('<meta name="viewport" content="width=1024" />'); }
		</script>

	  <meta property="og:title" content="Mugabe mourns fallen comrades"/>
						<meta property="og:type" content="article"/>
						<meta property="og:url" content="https://www.dailynews.co.zw/articles/2017/06/04/mugabe-mourns-fallen-comrades"/>
						<meta property="og:image" content="https://www.dailynews.co.zw/data/media/00000569/Original__zoom.jpg"/>
						<meta property="og:site_name" content="DailyNews Live"/>
						<meta property="og:description" content="HARARE - President Robert Mugabe yesterday told Zanu PF supporters of his heartache at witnessing the high number of deaths that the former liberation movement has had to contend with this year — including having to preside over their burials at the National Heroes Acre.

Speaking at the burial..."/>  <meta name="twitter:card" content="summary">
						<meta name="twitter:title" content="Mugabe mourns fallen comrades">
						<meta name="twitter:description" content="HARARE - President Robert Mugabe yesterday told Zanu PF supporters of his heartache at witnessing the high number of deaths that the former liberation movement has had to contend with this year — including having to preside over their burials at the National Heroes Acre.

Speaking at the burial...">
						<meta name="twitter:domain" content="www.dailynews.co.zw">
						<meta name="twitter:image:src" content="https://www.dailynews.co.zw/data/media/00000569/Original__square.jpg">
						<meta name="twitter:site" content="@dailynewszim">
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-17302690-1', 'auto');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

</script></head>
	
	<body id="ctl00_Body" class=" article ">

		<!-- BEGIN EFFECTIVE MEASURE CODE -->
		<!-- COPYRIGHT EFFECTIVE MEASURE -->
		<script type="text/javascript">
			(function ()
			{
				var em = document.createElement('script'); em.type = 'text/javascript'; em.async = true;
				em.src = ('https:' == document.location.protocol ? 'https://zw-ssl' : 'http://zw-cdn') + '.effectivemeasure.net/em.js';
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(em, s);
			})();
		</script>
		<noscript>
			<img src="//zw.effectivemeasure.net/em_image" alt="" style="position:absolute; left:-5px;" />
		</noscript>
		<!--END EFFECTIVE MEASURE CODE -->
	
		<form name="aspnetForm" method="post" action="/articles/2017/06/04/mugabe-mourns-fallen-comrades" onsubmit="javascript:try{return WebForm_OnSubmit();}catch(ex){}" id="aspnetForm">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="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" />


<script type="text/javascript">
//<![CDATA[
  (function() {{
		                var at = document.createElement('script'); at.type = 'text/javascript'; at.async = true;
		                at.src = '//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-51a1c2090ea507ee';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(at, s);
	                }})();//]]>
</script>

<input type="hidden" name="__EVENTVALIDATION" id="__EVENTVALIDATION" value="/wEWCQKa/YaNDwKbnLOwDwKdk+XhBQL4l/LfCAK0n7P0AgLB4d/lDwLAoMzvDAKar/yvCwKVlKvhAwyuBy03QecAB91aQsoeHuI3o+yg" />
		
			<div class="wrapper">
			
				
				<div class="header">
				<div>

					<div class="column">
						<div class="logo">
							<a id="ctl00_HeaderLink" href="/">DailyNews Live</a>
						</div>
						<div class="nav">
							<ul id="ctl00_HeaderMenu_List" class="navigation"><li class="home"><a href="/">Home</a></li><li><a href="/articles/news">News</a></li><li><a href="/articles/business">Business</a></li><li><a href="/articles/sport">Sport</a></li><li><a href="/articles/entertainment">Entertainment</a></li><li><a href="/articles/opinion-analysis">Opinion &amp; Analysis</a></li><li><a href="/articles/world">World</a></li><li><a href="/articles/africa">Africa</a></li><li><a href="/articles/features">Features</a></li><li><a href="/articles/letters-to-the-editor">Letters to the Editor</a></li><li class="classifieds"><a href="/classifieds">Classifieds</a></li><li class="directory"><a href="/directory">Yellow Pages</a></li></ul>
						</div>
						<div class="leaderboard-placeholder-advert"></div>
					</div>

				</div>
				</div>
			
				
				<div class="content">

					<div id="ticker"></div>
					<div id="ctl00_HeaderSearch_SearchForm" class="search">
	

    <input name="ctl00$HeaderSearch$Keywords" type="text" maxlength="32" id="ctl00_HeaderSearch_Keywords" title="Search" class="keywords" />
    <input type="submit" name="ctl00$HeaderSearch$SearchButton" value="GO" id="ctl00_HeaderSearch_SearchButton" class="submit" />


</div>

					
					

					<h1>Mugabe mourns fallen comrades</h1>

					<div class="left">                        
						
    
   <div id="article">

        <p id="ctl00_Content_ByLine" class="byline">Tendai Kamhungira &nbsp;&bull;&nbsp; 4 June 2017 12:50PM &nbsp;&bull;&nbsp; <a href="#comments">0 comments</a></p>
        

<div class="share_bar"> 

    
        <strong>Share this article: </strong>
    

    <!-- AddThis Button BEGIN -->
    <div id="ctl00_Content_AddThis1_Div" class="addthis_toolbox addthis_default_style addthis_16x16_style" addthis:url="https://www.dailynews.co.zw/articles/2017/06/04/mugabe-mourns-fallen-comrades">
	
        <a class="addthis_button_facebook"></a>
        <a class="addthis_button_twitter"></a>
        <a class="addthis_button_linkedin"></a>
        <a class="addthis_button_pinterest_share"></a>
        <a class="addthis_button_google_plusone_share"></a>
        <a class="addthis_button_email"></a>
        <a class="addthis_button_compact"></a>
        <a class="addthis_counter addthis_bubble_style"></a>
    
</div>
    <!-- AddThis Button END -->

</div>       
               
        <p>
	<strong>HARARE -</strong> President Robert Mugabe yesterday told Zanu PF supporters of his heartache at witnessing the high number of deaths that the former liberation movement has had to contend with this year &mdash; including having to preside over their burials at the National Heroes Acre.</p>
<p>
	Speaking at the burial of the late Naison Khutshwekhaya Ndlovu yesterday, Mugabe lamented the number of times that he and his colleagues had gathered at the national shrine to bury a fallen comrade.</p>
<p>
	&ldquo;This year has been a sad year, probably the saddest for our party and our nation because we have gathered here in the same way as we are doing today four times before, this now being our fifth&hellip;and that was all to bury our national heroes,&rdquo; a sorrowful Mugabe told mourners and Zanu PF supporters.</p>
<p>
	&ldquo;Diseases do not attack people on the basis of their positions, their cleverness or richness, it&rsquo;s a visitor, that ugly visitor that afflicts everyone regardless of that state that you hold in life.</p>
<p>
	&ldquo;So all of us get affected and we are forced to move onto the same chartered road towards destiny, all of you, us, got ill, get ill&hellip;the road is the same now for us.</p>
<p>
	&ldquo;Death is our destiny, we all die&hellip;, it&rsquo;s the way for all of us but we are human beings, we always would have wanted to live longer than the prescribed days for us on this earth. He who gives the life is the one who takes it, that&rsquo;s what our Bible says,&rdquo; he added.</p>
<p>
	Since the beginning of the year, Mugabe has buried former Mashonaland West provincial governor and resident minister Peter Chanetsa, who passed away in January, former CIO boss Zenzo Ntuliki, who died in April, Brigadier General James Murozvi, who also died in the same month and former chief justice Godfrey Chidyausiku, last month.</p>
<p>
	Mugabe said the late Ndlovu was the only remaining cadre of his generation whom he used to interact with.</p>
<p>
	Born in 1930, Ndlovu was six years junior to Mugabe.</p>
<p>
	&ldquo;He was a friend, we called him NK, that shall not be again. I called him babazala (father-in-law)&hellip;for those who have remained; none of them is fit for me to call babazala.</p>
<p>
	&ldquo;They are all youngsters. We, the two of us were their elders,&rdquo; Mugabe said, adding that he used to interact with Ndlovu, because they were of the same age.</p>
<p>
	Ndlovu, who died nearly 87 years-old, was Bulawayo&rsquo;s first black mayor in post-independent Zimbabwe and former deputy president of the Senate.</p>
<p>
	He died in Bulawayo in the early hours of Monday last week after a long battle with prostate cancer.</p>
<p>
	A veteran member of PF-Zapu, Ndlovu was the liberation movement&rsquo;s representative at the 1979 all-party Rhodesia conference at Lancaster House in London after escalation of the independence war, helping to broker a peace agreement and constitution for an independent Zimbabwe.</p>
<p>
	
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Daily News Article (Inline) -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7837974878174393"
     data-ad-slot="2356134262"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>

        <ul class="tags"><li><a href="/articles/tagged/National-Heroes-Acre">National-Heroes-Acre</a></li><li><a href="/articles/tagged/Robert-Mugabe">Robert-Mugabe</a></li><li><a href="/articles/tagged/Zanu-PF">Zanu-PF</a></li><li><a href="/articles/tagged/Naison-Khutshwekhaya-Ndlovu">Naison-Khutshwekhaya-Ndlovu</a></li><li><a href="/articles/tagged/Peter-Chanetsa">Peter-Chanetsa</a></li><li><a href="/articles/tagged/Zenzo-Ntuliki">Zenzo-Ntuliki</a></li><li><a href="/articles/tagged/James-Murozvi">James-Murozvi</a></li></ul>

    </div>

    
    

    
    <div id="ctl00_Content_Comments" class="comments">
	
    
                    
        
        
        
        <div id="ctl00_Content_CommentForm" class="post-comment">
		  
            
            <a name="post-comment"></a>
            <h3>Post a comment</h3>
            <p class="warning">
                Readers are kindly requested to refrain from using abusive,
                vulgar, racist, tribalistic, sexist, discriminatory and hurtful
                language when posting their comments on the Daily News website.<br />
                Those who transgress this civilised etiquette will be barred from
                contributing to our online discussions.<br />
                <strong>- Editor</strong>
            </p>

            <div class="form">

                <div class="row">
                    <label for="ctl00_Content_Name" id="ctl00_Content_Label1">Name:</label>
                    <input name="ctl00$Content$Name" type="text" maxlength="64" id="ctl00_Content_Name" />
                    
                </div>

                <div class="row">
                    <label for="ctl00_Content_EmailAddress" id="ctl00_Content_Label2">Email:</label>
                    <input name="ctl00$Content$EmailAddress" type="text" maxlength="256" id="ctl00_Content_EmailAddress" />
                    
                    
                    <em class="help">Your email address will not be shared.</em>
                </div>

                <div class="row">
                    <label for="ctl00_Content_Message" id="ctl00_Content_Label3">Message:</label>
                    <textarea name="ctl00$Content$Message" rows="6" cols="20" id="ctl00_Content_Message">
</textarea>
                    
                    &nbsp;
                </div>

                <div id="ctl00_Content_CaptchaRow" class="captcha row">
			
                    <label for="ctl00_Content_CaptchaCode" id="ctl00_Content_Label4">Verify:</label>                        
                    <input name="ctl00$Content$CaptchaCode" type="text" maxlength="4" id="ctl00_Content_CaptchaCode" class="input" autocomplete="off" />                                                                   
                    <input type="image" name="ctl00$Content$Captcha" id="ctl00_Content_Captcha" class="code" src="/captcha.aspx?3800D000DD00" alt="Verification image" border="0" />
                    <em class="help">Enter the three characters from the image on the right. This helps prevent automated 'bots' from submitting spam to the site. This field is NOT case-sensitive. If the characters are a bit hard to see, try refreshing the code by clicking the image.</em>
                
		</div>

                <p class="button">
                    <input type="submit" name="ctl00$Content$PostCommentButton" value="Post" onclick="javascript:WebForm_DoPostBackWithOptions(new WebForm_PostBackOptions(&quot;ctl00$Content$PostCommentButton&quot;, &quot;&quot;, true, &quot;Comment&quot;, &quot;&quot;, false, false))" id="ctl00_Content_PostCommentButton" />
                </p>

            </div>
            
            <script type="text/javascript">
                $(document).ready(function ()
                {
                    var _action = $('form').attr('action');
                    $('form').attr('action', _action + '#post-comment');
                });
            </script>

        
	</div>

    
</div>


					</div>

					<div class="right">
						

    <div class="rectangle-advert"></div>

    

<div class="popular">

    
            <h3>Popular this week</h3>
            <ul>
        
                <li>
                    <strong>1.</strong>
                    <a id="ctl00_Aside_Popular1_ArticleList_ctl01_Title" class="title" href="/articles/2017/05/30/minister-escapes-death-by-whisker">Minister escapes death by whisker
                        <span>20,012</span>
                    </a>
                    
                </li>
        
                <li>
                    <strong>2.</strong>
                    <a id="ctl00_Aside_Popular1_ArticleList_ctl02_Title" class="title" href="/articles/2017/06/01/tsvangirai-woos-top-army-bosses">Tsvangirai woos top army bosses
                        <span>17,589</span>
                    </a>
                    
                </li>
        
                <li>
                    <strong>3.</strong>
                    <a id="ctl00_Aside_Popular1_ArticleList_ctl03_Title" class="title" href="/articles/2017/06/01/now-mugabe-says-harare-stinks">Now Mugabe says Harare stinks
                        <span>15,904</span>
                    </a>
                    
                </li>
        
                <li>
                    <strong>4.</strong>
                    <a id="ctl00_Aside_Popular1_ArticleList_ctl04_Title" class="title" href="/articles/2017/05/29/another-big-week-for-mugabe-aides">Another big week for Mugabe, aides
                        <span>15,281</span>
                    </a>
                    
                </li>
        
                <li>
                    <strong>5.</strong>
                    <a id="ctl00_Aside_Popular1_ArticleList_ctl05_Title" class="title" href="/articles/2017/05/30/dump-coalition-tsvangirai-advised">Dump coalition: Tsvangirai advised
                        <span>13,300</span>
                    </a>
                    
                </li>
        
            </ul>
        

</div>
    
    <div class="mobile">
        <a href="/mobile"><img src="/web/images/download-mobile-app.png" alt="Download our mobile app" /></a>
    </div>

    <div id="ctl00_Aside_Galleries1_Panel" class="gallery">
	

    

            <h3 id="ctl00_Aside_Galleries1_GalleryList_ctl00_Title">In pictures</h3>
            <ul>

        

                <li>
                    <a id="ctl00_Aside_Galleries1_GalleryList_ctl01_Photo" class="photo" href="/galleries/2017/05/30/miombo-magic-music-festival"><img src="/data/media/00008091/Original__preview.jpg" alt="" border="0" /></a>
                    <a id="ctl00_Aside_Galleries1_GalleryList_ctl01_Link" class="title" href="/galleries/2017/05/30/miombo-magic-music-festival">
                        <span>Miombo Magic Music Festival &mdash; 6 images</span>
                    </a>
                </li>

        

                <li>
                    <a id="ctl00_Aside_Galleries1_GalleryList_ctl02_Photo" class="photo" href="/galleries/2017/05/12/police-tobacco-farmers-clash"><img src="/data/media/00007994/Original__preview.jpg" alt="" border="0" /></a>
                    <a id="ctl00_Aside_Galleries1_GalleryList_ctl02_Link" class="title" href="/galleries/2017/05/12/police-tobacco-farmers-clash">
                        <span>Police, tobacco farmers clash &mdash; 7 images</span>
                    </a>
                </li>

        

                <li>
                    <a id="ctl00_Aside_Galleries1_GalleryList_ctl03_Photo" class="photo" href="/galleries/2017/04/04/anti-kasukuwere-demo"><img src="/data/media/00007838/Original__preview.jpg" alt="" border="0" /></a>
                    <a id="ctl00_Aside_Galleries1_GalleryList_ctl03_Link" class="title" href="/galleries/2017/04/04/anti-kasukuwere-demo">
                        <span>Anti-Kasukuwere demo &mdash; 8 images</span>
                    </a>
                </li>

        

                <li>
                    <a id="ctl00_Aside_Galleries1_GalleryList_ctl04_Photo" class="photo" href="/galleries/2017/03/23/nera-demo"><img src="/data/media/00007752/Original__preview.jpg" alt="" border="0" /></a>
                    <a id="ctl00_Aside_Galleries1_GalleryList_ctl04_Link" class="title" href="/galleries/2017/03/23/nera-demo">
                        <span>Nera demo &mdash; 10 images</span>
                    </a>
                </li>

        

                <li>
                    <a id="ctl00_Aside_Galleries1_GalleryList_ctl05_Photo" class="photo" href="/galleries/2017/03/22/zanu-pf-women-s-league-protest"><img src="/data/media/00007745/Original__preview.jpg" alt="" border="0" /></a>
                    <a id="ctl00_Aside_Galleries1_GalleryList_ctl05_Link" class="title" href="/galleries/2017/03/22/zanu-pf-women-s-league-protest">
                        <span>Zanu PF Women&#39;s League protest &mdash; 4 images</span>
                    </a>
                </li>

        

            </ul>

        


</div>


					</div>

				</div>
				
				
				<div class="footer">

					<div class="top-links">
						<div class="column">
						
							<div class="left">
								

<div class="popular">

    
            <h3>Popular this week</h3>
            <ul>
        
                <li>
                    <strong>1.</strong>
                    <a id="ctl00_ctl10_ArticleList_ctl01_Title" class="title" href="/articles/2017/05/30/minister-escapes-death-by-whisker">Minister escapes death by whisker
                        <span>20,012</span>
                    </a>
                    
                </li>
        
                <li>
                    <strong>2.</strong>
                    <a id="ctl00_ctl10_ArticleList_ctl02_Title" class="title" href="/articles/2017/06/01/tsvangirai-woos-top-army-bosses">Tsvangirai woos top army bosses
                        <span>17,589</span>
                    </a>
                    
                </li>
        
                <li>
                    <strong>3.</strong>
                    <a id="ctl00_ctl10_ArticleList_ctl03_Title" class="title" href="/articles/2017/06/01/now-mugabe-says-harare-stinks">Now Mugabe says Harare stinks
                        <span>15,904</span>
                    </a>
                    
                </li>
        
                <li>
                    <strong>4.</strong>
                    <a id="ctl00_ctl10_ArticleList_ctl04_Title" class="title" href="/articles/2017/05/29/another-big-week-for-mugabe-aides">Another big week for Mugabe, aides
                        <span>15,281</span>
                    </a>
                    
                </li>
        
                <li>
                    <strong>5.</strong>
                    <a id="ctl00_ctl10_ArticleList_ctl05_Title" class="title" href="/articles/2017/05/30/dump-coalition-tsvangirai-advised">Dump coalition: Tsvangirai advised
                        <span>13,300</span>
                    </a>
                    
                </li>
        
            </ul>
        

</div>
							</div>
							<div class="twitter">                            
								<h3>@dailynewszim</h3>
								<div class="tweet"></div>
							</div>
						
						</div>                    
					</div>

					<div class="middle">
						<div class="column">
							<ul id="ctl00_FooterNav_List" class="navigation"><li class="menu1"><a href="/">Home</a></li><li class="menu2"><a href="/about">About</a></li><li class="menu3"><a href="/galleries">Galleries</a></li><li class="menu4"><a href="/cartoons">Cartoons</a></li><li class="menu5"><a href="/contact">Contact</a></li><li class="menu6"><a href="/account/profile">Subscribe</a></li><li class="menu7"><a href="/privacy-policy">Privacy Policy</a></li></ul>
							<ul class="more">
								<li><a href="http://www.facebook.com/DailyNewsZim" class="facebook">Like on Facebook</a></li>
								<li><a href="http://www.twitter.com/DailyNewsZim" class="twitter">Follow on Twitter</a></li>
								<li><a href="/mobile" class="mobile">Go Mobile</a></li>
							</ul>
						</div>
					</div>

					<div class="bottom column">
						<p class="copyright">
							&copy; 2017 Associated Newspapers of Zimbabwe (Pvt) Ltd. All Rights Reserved.
						</p>
						<p class="builders">
							<span>Made in Zimbabwe<br />Design & development by C2 Media</span>
							<a href="http://www.c2.co.zw/" title="Website design and development" class="c2">C2 Media</a>
							<a href="http://zwee.ly/" title="Local. Mobile. Social." class="zweely">Zweely</a>
						</p>
					</div>

				</div>
			
			</div>
			
		

<script type="text/javascript">
//<![CDATA[
website.gallery.init();//]]>
</script>
</form>
		
		
		<!--[if IE 6]>
			<div id="ie6-warning" class="ie6-warning">You are using an outdated browser - this website may not appear as intended.  Please <a href="http://www.microsoft.com/ie" target="_blank">upgrade</a> to a newer version.</div>
		<![endif]-->
				
		
		<script type="text/javascript">
			website.init();
		</script>

		<script type="text/javascript">

			var __adz = { id: '687623', ads: [] };
			$('div.leaderboard-advert,div.rectangle-advert,div.banner-advert,div.wideskyscraper-advert').each(function ()
			{
				var $ad = $(this);
				var id = 'ad' + Math.round(Math.random() * 1000)
				var classname = $ad.attr('class').replace(/-advert/gi, '');
				$('<div></div>').addClass(classname).attr('id', id).appendTo($ad);
				__adz.ads.push({ div: id, format: classname });
			});
			
			var $ad = $('div.leaderboard-placeholder-advert');
			var id = 'ad' + Math.round(Math.random() * 1000);
			$('<div></div>').addClass('leaderboard').attr('id', id).appendTo($ad);
			__adz.ads.push({ div: id, format: 'leaderboard', placeholder: 'dailynewsbanner' });

			(function ()
			{
				function async_load()
				{
					var s = document.createElement('script');
					s.type = 'text/javascript';
					s.async = true;
					s.src = 'https://www.adz.co.zw/res.js';
					var x = document.getElementsByTagName('script')[0];
					x.parentNode.insertBefore(s, x);
				}
				if (window.attachEvent)
					window.attachEvent('onload', async_load);
				else
					window.addEventListener('load', async_load, false);
			})();

		</script>
		
	</body>
	
</html>
